Slowness in Netaxept Administration - INC0576266

Incident Report for Nets Netaxept

Resolved

This incident has been resolved.
Posted Dec 06, 2023 - 19:45 CET

Identified

We have identified an issue with slowness in the Netaxept Administration.
Our tech-team is working on a solution.
Posted Dec 06, 2023 - 07:45 CET
This incident affected: Netaxept Merchant Administration.