Netaxept slow merchant Administration - INC0588469

Incident Report for Nets Netaxept

Resolved

This incident has been resolved.
Posted Jan 30, 2024 - 10:25 CET

Investigating

We are currently investigating an issue with Netaxept administration being slow.
Posted Jan 30, 2024 - 06:00 CET
This incident affected: Netaxept Merchant Administration.