SEK payouts for a few swedish merchants - INC0611255
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 13:15 CEST
Identified
We are currently fixing an issue that causes a slight delay in SEK payouts for a small number of swedish merchants
Posted Apr 16, 2024 - 11:25 CEST
This incident affected: Netaxept Other Components.