Slowness on Netaxept Administration - INC0600475
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 16:30 CET
Identified
We have identified slowness on Netaxept Administration
Posted Mar 12, 2024 - 06:52 CET
This incident affected: Netaxept Merchant Administration.