Delay in Settlement report delivery - INC0596561
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 13:53 CET
Investigating
We are currently investigating this issue.
Posted Feb 28, 2024 - 10:00 CET
This incident affected: Netaxept Other Components.