Slowness on Netaxept Admin - INC0600179
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 16:37 CET
Identified
We have identified slowness on Netaxept Administration
Posted Mar 11, 2024 - 08:30 CET
This incident affected: Netaxept Merchant Administration.