Phone system down

Incident Report for Nets Netaxept

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 13:37 CET

Update

Our phone system provider has identified the issue and is implementing a workaround.
Posted Mar 10, 2026 - 10:27 CET

Investigating

Our customer support phone lines are temporarily unavailable. We are actively investigating the issue.

https://payments.nets.eu/contact-support
Posted Mar 10, 2026 - 09:10 CET
This incident affected: Netaxept Other Components.