Phone system down

Incident Report for Nets Netaxept

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 14:10 CEST

Investigating

We’re currently experiencing issues with our phone system and are unable to take calls at this time.
Our team is actively working to resolve the issue as quickly as possible.
In the meantime, please reach out to us via email.
Posted Jun 17, 2025 - 13:45 CEST
This incident affected: Netaxept Other Components.