Slowness in Netaxept Administration - INC0598753
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 18:30 CET
Investigating
We are currently investigating an issue that might cause slowness or timeouts in Netaxept Administration.
Posted Mar 06, 2024 - 08:00 CET
This incident affected: Netaxept Merchant Administration.