Tietoevry Banking Incident - INC0738957

Incident Report for Nets Netaxept

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 07:55 CEST

Identified

Tietoevry has confirmed an incident affecting 3D Secure transactions - as a result we are seeing elevated failure levels on our platforms. This impacts mainly Finnish merchants
Posted Apr 03, 2025 - 07:15 CEST
This incident affected: Netaxept Terminal and Netaxept API.