Merchant Administration slowness - INC0594780
Incident Report for Nets Netaxept
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 16:00 CET
Identified
We have identified slowness in Admin page responsiveness.
Posted Feb 21, 2024 - 10:00 CET
This incident affected: Netaxept Merchant Administration.